Page tree
Skip to end of metadata
Go to start of metadata

Was tun, wenn Autodiscover trotz korrekt eingetragenem Autodiscover-CNAME nicht funktioniert?

Autodiscover versucht (neben diversen lokalen Lookups) folgende Methoden, um die Konfiguration der Konten automatisch herauszufinden:

  1. Test via https://ihredomain.tld:443/Autodiscover/Autodiscover.xml
  2. Test via https://autodiscover.ihredomain.tld:443/Autodiscover/Autodiscover.xml
  3. Test über die "Autodiscover-Redirection-Method". Das ist prinzipiell ein Aufruf von http://autodiscover.ihredomain.tld:80/Autodiscover/Autodiscover.xml wo ein Redirect auf das richtige OWA, also z.B. https://owa.liveapp.ch/Autodiscover/Autodiscover.xml erwartet wird
  4. Test via DNS SRV Record Redirection-Method. Hier wird im DNS nach einem Eintrag _autodiscover._tcp.ihredomain.tld gesucht der auf die Adresse des OWA auflösen muss

Methode 1 und 2 schlagen bei Hosted Exchange immer Fehl, da hier entweder gar keine Antwort auf Port 443/HTTPS geliefert wird oder aber (wenn z.B. ein DNS-Eintrag *.ihredomain.tld existiert) ein Webserver die Anfrage entgegen nimmt auf dem a) kein zum Namen passendes SSL-Zertifikat zurück kommt und b) unter der Adresse /Autodiscover/Audodiscover.xml auch keine korrekte Konfiguration zurückgeliefert wird.
Methode 3 funktioniert dann allerdings. Das können Sie selbst testen indem Sie in Ihrem Browser http://autodiscover.ihredomain.tld:80/Autodiscover/Autodiscover.xml öffnen. Es müsste ein Fenster erscheinen wo Sie sich mit einem Ihrer Hosted-Exchange-Accounts authentifizieren müssen. Danach (bzw. eigentlich schon vor Eingabe der Zugangsdaten) werden Sie automatisch auf https://owa.liveapp.ch/Autodiscover/Autodiscover.xml weitergeleitet

Grosses Problem an Autodiscover ist, dass sich viele Mail-Clients unterschiedlich verhalten (sowohl in der Reihenfolge der Methoden als auch im Verhalten, wenn eine der Methoden fehl schlägt). Unter MacOS scheint es z.B. teilweise so zu sein, dass wenn beim Aufruf von der URL in Methode 1 oder 2 ein Webserver mit SSL-Zertifikat antwortet MacOS/Apple Mail das entsprechende Zertifikat anzeigt und strikt versucht auf dieses System zu verbinden. Korrekterweise müsste Apple Mail allerdings die anderen Autodiscover-Methoden durchprobieren, so auch Methode 3 die funktionieren sollte.

Grundsätzlich hält sich unser Exchange-System aber an die Richtlinien, wie Autodiscover gemäss Implementation von Microsoft funktioniert. Das lässt sich auch via https://testconnectivity.microsoft.com/ mit einem der Autodiscover-Tests überprüfen.

Um das Problem zu lösen erstellen Sie zusätzlich (oder anstelle) des bestehenden Autodiscover-CNAME-DNS-Eintrags auch noch den Eintrag für die SRV Record Methode (4). Dieser muss folgendermassen aussehen:

_autodiscover._tcp.ihredomain.tld. 3600 IN SRV 0 100 443 owa.liveapp.ch.

Wahl der Autodiscover-Methoden beeinflussen

In Outlook für Windows lassen sich die einzelnen Autodiscover Methoden konfigurieren. Details dazu finden Sie hier: https://docs.microsoft.com/en-us/outlook/troubleshoot/profiles-and-accounts/unexpected-autodiscover-behavior

Alle für Hosted Exchange irrelevanten Autodiscover-Methoden lassen sich auch mit folgenden Registry-Einträgen deaktivieren (Benutzung nur für erfahrene Benutzer empfohlen - bei Fragen wenden Sie sich bitte zuerst an unseren Support):

Outlook_DisableNoneHEXAutodiscover.reg

  • No labels